Windows cannot access the specified device path or file. you may not have appropriate permissions

bug

#1

Whenever a new update comes, i download it, after that… the sostronk app disappears. Then when i try to open(double click) the sstk app from my desktop(icon), i get this error :- "windows cannot access the specified device path or file. you may not have appropriate permissions"
Then i have to uninstall sstk( that too the uninstaller doesn’t get deleted) So i have to manually delete the files and temp files of sostronk. and install again from the installer. This happens everytime i download the update.


#2

Do you get any kind of error when its applying the update? Something that says it failed to delete installation directory.


#3

No, I don’t get any error WHILE APPLYING the update. The update window pops up when i run the sostronk app, i click on download, and then the sostronk app disappears. That’s it. I then wait for couple of minutes or even more, nothing happens, app never opens like normally it used to open after the update gets downloaded. So then when i manually try to run the app again from desktop, it gives my that error which is the TITLE itself.


#4

That is when its applying the update, my guess is its trying to delete SoStronk.exe but its getting stuck. The previous case where I saw this happen was on another player’s machine-

  1. SoStronk updater asks Windows to delete SoStronk.exe, Windows doesn’t reply to that request for a long time.
  2. Because the updater failed to delete SoStronk.exe, it aborts the update.
  3. Somehow after some time Windows suddenly remembers “Oh wait I got a request to delete SoStronk.exe, let me do that now”, and it goes ahead and deletes SoStronk.exe.

This might be happening in your case as well. The other player fixed it by running a Check Disk on his C: drive, can you try that?


SoSotronk App Issues