Unable to play on SoStronk despite app running

I logged in from steam and downloaded SoStronk App as the site instructed . So after finishing the installation, I tried the app and i tried joining a bangalore server but when the app opened cs:go, it gets to the continue button and then it comes back to home page of cs:go.
And another problem is that when I joined a deathmatch server, I reached to team selection then it gets disconnected saying “Install App from SoStronk.com and connect to your steam id to join this server”

when ever i log into my sostronk acc from my sostronk app and then try and connecting to a server to play it shoes a werid error after full loading of the map, the error is like this please connect from sostronk app or update your app, but i have already logged in from the app and conencted via app only still reciving this msg, but yes i can connect to pvt comp as a spectator and watch the full game but cant connect as a player neither in comp or single pug svs + i have tried restarting and reinstalling the app to solve the problem but nothing happned !!!

Please Help

Thanks for asking this question. I have moved this to the right category so that you get help faster. @shaan7

Hi @constantine1 are you still having this issue? Asking to make sure because its unfortunately been a long time since you posted the question.

Oh yea. I didn’t check the date on the OP

also having this same issue is there a fix for it yet ???

What is the exact error message you get? A copy paste of the error will be useful :slight_smile:

Not getting any message i paste the ip into the command console and i load up and then nothing. straight back to csgo main menu hahah

After the “Loading” screen is gone and it does a countdown from 5,4,3,…0, don’t press Continue and just wait, you will see the error.

Just says that the sostronk server is shutting down even though theres people in the server.

That would be if the server encountered some error. It then stops anyone from connecting (and you might be still seeing people there because they’re still not kicked by the server).

However, this is very rare, and only in error scenarios. Why don’t you try creating a server yourself (use the Create Server option in app) and join that to see if that works?

I am having the same issues. tried making my own server i am still getting kicked out . “you have been kicked out from the session” even though i type .r -_- . please help me out i have tried uninstalling then downloading again fron the website.

I am getting the same error now. I installed sostronk, today i upadted it too. Once the loading screen is done, i don’t get to choose the team or anything, it just redirects me to the home of csgo. This is happening only with PUG for me. I haven’t tried SCRIM, but DM worked fine.

@N_H you can see the error message by either waiting for the 5…4…3…2…1 thing to finish after the map loads (don’t press enter) or open the console (use ~ key) at the main menu to see the error.

I installed SosTronk app reecently and when i try to join PUG it loads and when its finished i m redirected to the main menu and theres this error message “join from PUG tab from Sostronk app”.Due to this i m unable to play and gettin constant cooldowns. Please try to solve this i m strtin to hate this app. :frowning: @shaan7

That error will come up if-

  • You are joining the wrong server. Make sure you use the server address from the JOIN button which comes up after you have Accepted a game from the PUG matchmaking
  • You are using a different Steam ID to launch CS:GO than the one connected to your SoStronk account