Sostronk Akros Anticheat error

Akros anticheat is not working. I have tried all the troubleshooting options. The troubleshoot button in the app does not do anything. It returns this error : Unable to start anticheat service.

I located the akros anticheat exe file in sostronk folder. When I tried to run it, I got this error. (In screenshot).
I got 2 successive cooldowns (30min and 2hrs). Please help. Thanks.

@akS @shaan7

Something on your PC is interfering with Anticheat files. I would suggest you do a clean boot first to see if it helps.

https://support.microsoft.com/en-us/help/929135/how-to-perform-a-clean-boot-in-windows

1 Like

Tried in clean boot. Still getting same error. When I join sostronk deathmatch using IP from the app I get no error. Only for PUGs I face this error. I am attaching some screenshots.

Also taskmanager does not show akros anti cheat in the list of services or running programs. Please help. @akS @shaan7 Sorry for tagging both, but I know both of you are helpfull. Thanks !

EDIT : In taskmanager I can only see AkrosLauncher.exe. None of the other akros stuff are listed in the running processes.

1 Like

I have following visual c++ x64 and x86 versions installed : 2012, 2013 and 2017.
When I tried to install the 2015 version, it gives me a “setup failed” error. Saying similar program is already installed on your pc.

Open Task Manager, then start SoStronk.

Do you see AkrosLauncher.exe and then do you see it vanish?

If thats the case we are investigating this issue and a fix should be out soon.

1 Like

I opened Task Manager and then sostronk. AkrosLauncher.exe showed up and it DID NOT vanish. It is still there. But the anticheat section in the sostronk app has a greyed out START button. And Task Manager does not show any other Akros processes other than the launcher exe.

Akros only runs when CSGO is running. Can you verify what happens when you start CSGO. Do you see akros.exe running in task manager?

1 Like

I started csgo while sostronk is running. Still no akros.exe file. Only launcher exe.

EDIT : Please launch a test server that requires anti cheat just like the PUG servers do. So we can test the anti cheat without receiving cooldowns. THANKS !

connect 13.235.36.194:10060

Retake server is a test server.

1 Like

Getting this error. (Check Screenshot).

Some people have reported starting Steam as Admin helps since in the past they ran steam at some point as an Admin and now the only way Akros can monitor CSGO is if Steam is run as Admin.

1 Like

Tried. Still gives same error as before.

Thanks for the screenshots. I have informed the dev of the Anticheat. He will have look, however you will have to wait. Please understand that we will look into all the errors, with some time they will eventually be fixed. If you wish for a refund while we investigate these issues please write to support@sostronk.com and we will get it done asap.

1 Like

Thanks for helping. Please be informed that I had no problems with odin anti cheat. Maybe devs changed the way akros works compared to odin.

I do not mind waiting. In the meanwhile post any suggestions in this thread so I can try them out and share the results.

Hope it is fixed soon. Cheers.

Hello @akS. Bit of an update. I reinstalled windows 10 and tried sostronk again. Meanwhile there were updates to sostronk and akros anticheat. I tried joining the empty retake server from sostronk app. However I got this error : Code Integrity Error. (Check screenshot).
So I hit the troubleshoot button while csgo was running. It returned with this message : Everything seems to be fine. (Check screenshot).
I looked in the anti cheat tab in sostronk settings. The start button is greyed out. But it says anticheat is running.


Please inform the devs. And send suggestions.

@Tex_M

[AAC] Code Integrity violation kick

In this case your unusual settings with Test Signing, Debug Mode and HypervisorLaunchType settings is causing this.

You can check that by opening cmd with admin permissions and typing bcdedit .

Debug Mode needs to Off
Test Signing needs to be Off
HypervisorLaunchType needs to be Off

1 Like

I have the same issue my anticheat just shows errored… I dont have akros on my taskmanager at all… I have tried reinstalling the app but it did not help.

my task manager ss

How do I change these settings ? Through cmd ? This is what I see when I type bcdedit in cmd.

Press Windows logo key + X , then hit A to run Command Prompt as administrator. In Command Prompt window, type bcdedit /set hypervisorlaunchtype off and hit Enter key to execute this command.

Restart computer, test it on retake server.

connect 13.235.36.194:10060

1 Like